Important Security Notice Regarding Third‑Party Vendor Incident ( CORE / BridgePay )

Incident Report for HSCloud Suite

Update

This post is to update our customers about the security‑related incident from our third‑party vendor, CORE and their clearinghouse partner Bridgepay that is currently causing an interruption to payment processing for some of our clients. Please see the following link for details:

https://hsgovtech.atlassian.net/wiki/x/AQD_yw
Posted Feb 11, 2026 - 10:09 EST

Monitoring

This notice is to inform customers of a security‑related notification we received from our third‑party vendor, CORE and their clearinghouse partner Bridgepay. Out of an abundance of caution and in alignment with our commitment to transparency and data protection, we want to ensure you are aware of the situation and the actions currently underway. This incident is not related to HS GovTech systems, infrastructure, or security controls, but because CORE supports certain payment‑processing functions for some clients, we are sharing this update in the interest of transparency and proactive communication.

Full details can be found in the link below:
https://hsgovtech.atlassian.net/wiki/x/AgDZyw
Posted Feb 09, 2026 - 20:13 EST
This incident affects: My Health Department (HSPay).